
3) Computer Aided Design of microsystems structures 
and elements 

3.1. INTRODUCTION 

MEMS and microsystems design differs from traditional engineering design is that 

in additional to the design for structural integrity and performance of the device or system, 

the designer’s responsibility also include signal transduction, fabrication processes and 

manufacturing techniques, packaging, assembly and testing. There are three major 

interrelated tasks in microsystems design. The first one is the fabrication process flow 

design, the second one is the electromechanical and structural design, and the last is 

design verification which includes assembly, packaging and testing. 

In figure 3.1 is presented an overview of the mechanical design of microsystems.  

 

Fig. 3.1 An overview of mechanical design of microsystems 

INITIAL DESIGN CONSIDERATIONS 
a) Design constrains: 

• Customer demands: applications, product specifications, operating 
environments 

• Time to market 
• Environmental conditions: temperature; humidity; chemical; optical. 
• Size and weight limitations 



• Life expectance 
• Availability of fabrication facility 
• Costs 

b) Selection of materials: (for substrate, components and packaging materials) 
• Substrate: Silicon, GaAs, Quartz and polymers 
• Thermal/electric insulation: SiO2 
• Doping materials: B, P and As 
• Mask materials: SiO2, Si3N4, quartz 
• Packaging materials: Adhesive, eutectic solder alloys, wire bond, 

encapsulation 
• Photoresists for photolithography 
• Thin films depositions 

c) Selection of Manufacturing technique(s) and fabrication processes: 
• Micromanufacturing techniques: Surface micromachining, Bulk 

manufacturing 
d) Signal transduction: Types, Locations, Transduction methods, Interconnects 

 

Fig. 3.2 Signal transduction Diagrams 

e) Electromechanical systems: 
• Power supply 
• Interface of MEMS/microsystems and microelectronics 

f) Packaging: Materials, Process design, Assembly strategy and methods, 
Testing 

• Die passivation 
• Media and System protection 
• Electric interconnect 
• Electrical interface 



• Electromechanical isolation 
• Signal conditioning and processing 
• Mechanical joints (anodic bonding, TIG welding, adhesion, etc.) 
• Processes for tunneling and thin film lifting 
• Strategy and procedures for system assembly 
• Product reliability and performance testing 

The diversity and complexity of microsystems design used to take about 5 years to 

complete by the industry. Therefore, manually designed microsystems is no longer a 

viable option in practice. In 1990s the computer-aided design (CAD) was made 

commercially available to the industry. The design cycle has since drastically reduced to 3 

to 6 months for new microsystems products using CAD as a tool.   

In MEMS technology, CAD is defined as a tightly organized set of cooperating 

computer programs that enable the simulation of manufacturing processes, device 

operation and packaged Microsystems behavior in a continuous sequence, by a 

Microsystems engineer. 

MEMS CAD software is used for matching system specifications, optimizing device 

performance, designing packages, validating fabrication process, shortening development 

cycle and reducing development cost. 

In general, CAD for microsystems involves 3 major databases: 

• Electromechanical design database 
• Materials database 
• Fabrication database 

In figure 3.3 is presented the general structure of CAD for microsystems design. 

 



Fig. 3.3 General structure of CAD for microsystems design 
 

 

Fig. 3.4 MEMS CAD System flow 

 

Fig. 3.5 MEMS CAD Design flow 

3.2. SOFTWARE TOOLS FOR CAD AND DFM 

SELECTION OF A CAD PACKAGE: 
• User friendliness 
• The adaptability of the package to various computer and peripherals 
• Interface of this CAD package with other software, e.g. nonlinear 

thermomechanical analyses and the integration of electric circuit design 
• Completeness of material database in the package 
• The versatility of the built-in finite element or boundary element codes 
• Pre- and post-processing of design analyses by the package 
• Capability of producing masks from solid models 
• Provision for design optimization 
• Simulation and animation capability 
• Cost in purchasing or licensing and maintenance 



 

COMMERCIALLY AVAILABLE SOFTWARE: 
• Coventorware from Coventor – http://www.memcad.com 
• IntelliSuite from Intellisense Inc. (Corning) – http://www.intellisense.com 
• MEMS ProCAETool from Tanner Inc. – http://www.tanner.com 
• MEMScap from MEMScap Inc. – http://www.memscap.com 
• SOLIDIS from ISE Inc. - http://www.ise.com 
• COMSOL Multiphysics from COMSOL - https://www.comsol.com/ 

DEVICE DESIGN: 
• Cadence/OrCAD 16.6-2015 
• LEdit 
• Spice 
• MATLAB 

PROCESS DESIGN: 
• TSuprem (fabrication cross-

section) 
• IntelliSuite 
• AnisE (bulk silicon etching)  

ANALYSIS: 
• MEMCAD 
• IntelliSuite 
• ANSYS 
• CoventorWare 
• COMSOL Multiphysics 

 
a) CoventorWare 

CoventorWare is a fully integrated MEMS design environment that offers the most 

productive path to manufacturable MEMS. Its unique capabilities let the user explore 

design alternatives efficiently and converge on a device that has the highest probability of 

success without using computationally intensive FEM tools. Then CoventorWare can be 

used to perform FEM/BEM analysis on critical areas to fine-tune the device. 

CoventorWare provides electromechanical component libraries and field solvers. 

Therefore, design and simulations of many MEMS and microfluidics application can be 

realized with CoventorWare. For instance, accelerometers, switches, biochips, and mirror 

designs can be realized.  

The software has three modules. These are Architect, Designer and Analyzer. 

Architect is a schematic-based system level modelling tool, in which different designs with 

different materials can be realized. Designer is a physical design tool that contains 2-D 

layout editor and the model generator. Analyzer is a physical and numerical analysis tool. 

http://www.ise.com/
https://www.comsol.com/


Analyzer has many solver types such as MEM Electro (EM solver), MEM Mech 

(mechanical solver) or Microfluidics solver.  

 

Fig. 3.6 CoventorWare tool flow 

ARHITECT 

Architect is a behavioral design and simulation environment using parameterized 

libraries. A realistic MEMS simulation requires that 3-D representations of multiphysics 

devices be created and boundary conditions applied such that the devices can be 

evaluated in multiple degrees of freedom. The complexity of the modeling and the 

computation of the equations used to represent the models demand a streamlined 

approach that enables the design procedure to be both fast and accurate.  

Coventor’s Architect is a new MEMS paradigm that uses a three-step approach for 

accurate high-level design and simulation: 

• Capture a design in circuit form using libraries of parametric elements. The 
capture process uses placement and interconnect techniques familiar to 
digital designers. 

• Simulate device behavior using SPICE-like simulation for mixed domain 
technologies. The result is an accurate and rapid solution available in tabular 
and graphical formats. 

• Optimize design using advanced techniques such as sensitivity and Monte 
Carlo analyses. Hundreds of design iterations can be evaluated quickly to 
produce a device that minimizes the influences of manufacturing tolerances. 

DESIGNER 



Designer is an efficient front-end design tool for creating models of MEMS devices. 

It combines a fully functional 2-D mask layout program, process editor, materials 

properties database, and a preprocessor module for 3-D model generation and viewing. 

The models can be used for export to FEM/BEM simulation verification, while the 2-D files 

can be exported for mask set foundry processing. 

Designer assists users in designing MEMS devices in the following ways: 

• 2-D layouts created, imported, generated, or exported Material properties 
database to store characteristics of the materials used in the fabrication 
process. Properties may be specified as scalars, polynomials, or in table 
format. The database is shared by other Coventor software. 

• Process editor allowing real foundry steps to be emulated, including etching 
through multiple layers and partial backside etching. The process editor is 
used in 3-D model creation and in creation of layouts from high-level circuit 
schematics. 

• 3-D models automatically created from a 2-D description and process 
information and viewed in Preprocessor. 

ANALYZER 

Analyzer is Coventor’s extensive suite of 3D field solvers designed specifically for 

MEMS applications. Analyzer gives the ability to analyze and simulate the behavior of 

MEMS devices that are subject to multiple physical effects. The sub modules are listed 

below: 

• MEMS Solvers: Perform complex, fully coupled, multi-domain physics 
analysis with the comprehensive suite of MEMS-specific solvers. It also 
performs multi-domain interaction between true-coupled electrostatic, 
mechanical, PZE, and thermal analyses. 

• Query, View, and Compare Results: Quickly examine results of analyses in 
selectable presentation formats. The powerful query capability enables the 
user to easily extract a wide variety of results over a wide range of 
parametric conditions. 

• Automatic Meshing: MEMS structures will be meshed with precision using 
the automated mesh generator. Various mesh control techniques, such as 
boundary refinement and bias are available. 

• Microfluidic Solvers: It Examines chemical transport and containment physics 
of lab-on-chip applications in DNA, protein, and chemical analyses. It also 
analyzes full 3D electrophoreses, electro-osmosis, and mixed electro-
kinetics. Perform a multi-phase analysis to predict drop or bubble behavior 
for inkjet or dispensing applications. 

 



  

  

Fig. 3.7 CoventorWare software blocks 
 

 
Fig. 3.8 Typical CAD Software: CoventorWare windows 

TASK SEQUENCE ACCOMPLISHED BY A CAD TOOL 
• Layout and process 
• Topography simulation 
• Boundaries, IC process results and material properties 
• Mesh generation 
• Device simulation 
• System-Level simulation 
• MEMS Control CAD 



b) Intellisuite 

Intellisuite is a registered trademark of IntelliSense Software Corporation. The 

MEMS device development using Intellisuite is given in the figure. 

 

Fig. 3.9 MEMS device development using Intellisuite 

The integrated seamless flow of Intellisuite is given in figure 3.10. 

 

Fig. 3.10 Intellisuite tool flow 

The software has several main modules and auxiliary modules. The main modules 

are Intelli Mask, Intelli Mask Pro, MEMaterial, IntelliFab, 3D Builder, AnisE, Thermo Electro 

Mechanical, Electro Magnetic, SYNPLE, RECIPE and Microfluidic. The auxiliary modules 

are 2D Viewer, 3D Geometry and EDA Linker. 

There are two kinds of approach to model a structure: top down approach and 

bottom up approach.  



 

Fig. 3.11 Top-Down / Bottom-Up Design 

TOP-DOWN APPROACH 

In Top-Down approach, models are designed using the basic elements and then 

simulated using software module called SYNPLE. The basic elements used are rigid plate, 

linear beams, comb-drives, anchors, beam joint etc. The brain behind SYNPLE is a 

powerful new system level simulator designed from the ground up for the MEMS and Nano 

communities. SYNPLE ships with advanced algorithms to solve complex differential 

equations with ease. It allows users to perform several analyses that are essential for 

complex MEMS/System design and synthesis. 

BOTTOM-UP APPROACH 

In Bottom-Up approach models are developed using the following process: 

• Mask layout creation using Intelli Mask:  
o Figure creation, Copying, Multi-copying 

• Fabrication process simulation: 
o IntelliFab: Build and visualize the MEMS structure based on foundry. 
o MEMaterial: To deal with material properties based on process. 

• Electro Mechanical analysis 
o Apply loads and boundary conditions 
o Mesh the structure - local refinement 
o Analyze the model for various input 

 
c) COMSOL Multiphysics 

COMSOL Multiphysics brings simulation and virtual prototyping to a far wider 

community of engineers. Key features are ready-made couplings between common 

physics, Model Tree, interactive meshing, merging components to build models, the ability 

to handle CAD assemblies, support for the multiphysics analysis of surface contact, and 



gains towards fully automatic solver selection. Users can also expand on the package’s 

internal material database by enacting an online search of the Matweb database and 

directly importing material properties. 

The MEMS Module is a collection of application modes and models for COMSOL 

Multiphysics with which one can model various MEMS devices and applications. It 

includes application modes for modeling of electrostatics, structural mechanics, 

piezoelectricity, film damping, and microfluidics. The MEMS Module Model Library shows 

how to use these application modes to model actuators, sensors, and microfluidic devices. 

The MEMS Module seamlessly connects to COMSOL Multiphysics and the other 

add-on modules in the COMSOL Multiphysics product line. One can also view and modify 

the models in terms of the underlying PDEs. The software thus offers a unique 

transparency because the model equations are always visible, and you have complete 

freedom in the definition of phenomena that are not predefined in the module. 

The table summarizes the most important MEMS couplings and some common 

devices using the MEMS Module. 

 Electromechanical Fluid-structure 
Interaction 

Microfluidics 

Phenomena/ 

coupling 

Electro-structural 

Electro-thermal 

Thermo-mechanical 

Thermal-electric-
structural 

Piezoelectric 

Piezoresistive 

Prestress modal 
analysis 

Stress stiffening 

Moving boundary using 
ALE technique 

Squeezed-film 
damping 

 

Pressure-driven flow 

Electroosmotic flow 

Electrophoresis 

Dielectrophoresis 

Electrothermal flow 

Mass transport 

Devices Cantilever beams 

Comb drives 

Resonators 

Micromirrors 

Thermomechanical 
actuators 

Inertial sensors 

Mechanical pumps and 
valves 

Lab-on-a-chip devices  

Microfluidic channels 

Micromixers 

Nonmechanical pumps 
and valves 

MEMS heat exchanges 



The MEMS Module Model Library consists of a set of models that demonstrate the 

use of this module for modeling of various types of MEMS devices. The purpose of these 

models is to assist in learning, by example, how to create sophisticated multiphysics 

models for design and analysis of microelectromechanical systems. 

In addition to serving as a reference, the model library is also gives a big head start 

while developing a model of a similar nature. 

These models are divided into 4 different groups: 

• Actuator models 
• Sensor models 
• Microfluidics models 
• Piezoelectric models 

d) MEMS Pro 

The MEMS Pro package includes a schematic entry tool, an analog and mixed 

analog / digital circuit level behavioral simulator, a statistical analyzer, an optimizer, a 

waveform viewer, a full-custom mask level layout editing tool, an automatic layout 

generator, an automatic standard cell placement and routing tool, a design rule checking 

feature, an automatic netlist extraction tool (from layout or schematic), a comparison tool 

between netlists extracted from layout and schematics (Layout Versus Schematic), and 

libraries of MEMS examples. 

MEMS specific key features also available in MEMS Pro encompass a 3D solid 

model generator using mask layout and process information, a 3D solid model viewer with 

cross-section capability, a process description editor, true curved drawing tools and 

automation of time consuming tasks using the MEMS Pro Easy MEMS features. 

Embedded features within ANSYS allow automatic mask layout generation from an 

ANSYS 3D Model and process description (ANSYS to Layout), as well as automatic 

MEMS behavioral Model generation in hardware description languages (Reduced Order 

Modeling). 

 



Fig. 3.12 MEMS Pro tool flow 

SCHEMATIC CAPTURE (S-EDIT) 

S-Edit is a fully hierarchical schematic capture program for MEMS and IC 

applications. The program also serves as a schematic entry front end to the T-Spice 

simulator, L-Edit/SPR automatic standard cell placement and router, and layout vs. 

schematic (LVS) netlist comparison programs. S-Edit and its associated libraries are 

technology independent; that is, the design may be built and tested before choosing a 

specific manufacturing technology and vendor. User-defined global symbols convey 

connection among nodes without wiring. S-Edit also supports global node naming so that a 

single symbol can represent several distinct nodes in the design. Using S-Edit, MEMS 

schematics can be designed to include signals in multiple energy domains. For example, 

the MEMS Library includes a set of examples of electro-mechanical schematic symbols 

and models.  

SIMULATOR (T-SPICE PRO) 

The T-Spice simulator provides full-chip analysis of analog, mixed analog/digital 

and MEMS designs using an extremely fast simulation engine that has been proven in 

designs of over 300,000 devices. For large circuits, the T-Spice simulator can be ten times 

faster than typical SPICE simulators. MEMS macromodels can be implemented in 3 

different ways in T-Spice. In the simplest form, MEMS devices may be modeled using 

equivalent circuits of standard SPICE components. Another method is to create table 

models from experimental data or finite element or boundary element analysis of the 

MEMS devices. A third method is to use the external functional model interface. This last 

method allows quick and easy prototyping of custom MEMS macromodels using a C code 

interface. 

The W-Edit graphical waveform viewer, embedded within T-Spice, displays analysis 

results, and automatically updates its display each time T-Spice simulates a circuit. 

Powerful optimization algorithms automatically determine device or process parameters 

that will optimize the performance of the design. Defining parameters to be varied, setting 

up optimization criteria, and choosing optimization algorithms is a cinch using the new 

Optimization Wizard. The Wizard prompts the user for the optimization criteria the program 

will need. Monte Carlo analysis generates “random” variations in parameter values by 

drawing them probabilistically from a defined distribution. This type of statistical analysis 

may be used to discover what effects process variation will have on system performance. 



 

LAYOUT EDITOR (L-EDIT) 

L-Edit is an interactive, graphical layout editor for MEMS and IC design. This full-

custom editor is fast, easy-to-use, and fully hierarchical. Primitives include boxes, 

polygons, circles, lines, wires, labels, arcs, splines, ellipses and tori. Drawing modes 

include 90°, 45°, and all-angle layout. Shortcuts are also available for quickly laying out 

circles, tori, pie slices, and “curved polygons” with true curved edges. Designs created in 

L-Edit are foundry ready. The MEMS Pro Toolbar in Version 4.0 gives access to MEMS 

specific design features. It gathers the creation of splines and ellipses, the display of 

vertex information, and the use of Easy MEMS features like the polar array feature and the 

plate release feature. It also includes access to the process definition graphical interface, 

3D modeler and viewer, MEMS specific DRC, and MEMSLib (the MEMS library).  

3D MODELER 

3D models can be created of the MEMS device layout geometry directly in LEdit 

using one of the many foundry fabrication process descriptions supported by MEMS Pro or 

by specifying the custom process. The 3D Solid Modeler permits views of surface and bulk 

micromaching steps including deposit, etch, and mechanical polishing. You can easily 

customize your view with features such as panning, zooming, cross-section modeling, and 

other viewing controls. 3D solid model geometry can be exported in a SAT, ANF or APDL 

format.  

3.3. BEAM DESIGN 

In MEMS design, the beam structure has many applications, including sensors, 

accelerometers, and RF switches. In the following part, will be described a simple example 

to understand how MEMS design is done.  

In the following part the software tool that will be used is CoventorWare. It will be 

designed a solution for an electrostatically actuated fixed beam with conformal supports. 

The example is educative for editing process sequence, creating the 3-D model, and 

simulation with electrostatic and mechanical solvers. The main structure and analyses that 

will be done is shown below. 



 

Fig. 3.13 Beam structure 

To start the software, on your desktop, double click on the CoventorWare shortcut 

icon or from the Start menu select Coventor → CoventorWare 2010. The first time you run 

the software, you will have to set a work directory, a temp directory, and a shared directory 

(default location). These directories will not have to be set again. After we set the project 

directory our procedure will:  

• Check and modify the Material Properties Database 
• View and modify the process flow 
• View and modify the 2-D mask design 
• Build a 3-D solid model 
• Mesh the model 
• Name faces and conductors 
• Simulate electrostatic and mechanical stimulus 

MATERIAL PROPERTIES DATABASE SETUP 

The Material Properties Database is the foundation of your design. This database 

stores properties for materials used for MEMS design. Materials or parameters can be 

added or modified at any time from this or from other dialogs in the software. The Function 

Manager provides access to the Material Properties Database in the top portion of the 

window, above the tabs. Material Properties Database access and setup is the first field in 

the Function Manager because the process is dependent on the materials in the Material 

Properties Database, and in turn, the rest of the design creation is dependent on the 

process file. The user designates the file path for the Material Properties Database file in 

the Users Settings dialog the first time CoventorWare is run. This setting can be changed 

from the Tools →User Settings menu. 



In this example, the Material Properties Database is checked and validated before a 

process file is created because the materials used in the process file must exist and have 

the correct values. The process file takes the materials and their values from the Material 

Properties Database. In the next step, properties for both Silicon_100 and Aluminum Film 

will be checked. These materials are used to construct the beam.  

The first step is to access the Material Properties Database. For this, in the 

Function Manager, click on the Start MPD Editor icon. In the Edit Materials dialog, click on 

the drop-down arrow beside the Materials field. Select the material named 

ALUMINIUM(FILM). If the material exists, check the property values (see Fig 3.14) against 

those in Table 1. If the material is not on the list click on New Material and in the dialog 

that opens enter ALUMINIUM(FILM). Set the properties from Table 1. Then, select 

SILICON_100 from the Materials drop-down menu and verify its material properties (see 

Fig 3.15). When finished in the Edit Materials dialog, click on Close. 

 
Fig. 3.14 Material Properties for ALUMINIUM(FILM) 

 

Fig. 3.15 Material Properties for SILICON_100 

 



 

Table 1 Material Properties for the example 

PROCESS EDITOR 

The process editor supplies the information to construct the 3-D model of the 

structure. The layers are created with deposition and etching steps. Adjustable process 

parameters are material thickness, sidewall angles, deposition type and mask polarity. The 

cross-section diagram of the structure is shown below. 

 

Fig. 3.16 Structure to be obtained 

A ground plane is overlaid with a nitride layer for isolation of the beam. A sacrifice 

layer of BPSG (boron phospho-silicate glass) is deposited on the nitride layer. It is etched 

to define the areas where the beam will be anchored to the nitride layer. The BPSG 

thickness sets the separation between the nitride layer and the thin aluminum beam to be 

built on top. After the entire wafer is deposited with aluminum, a selective etch defines the 

actual beam dimensions. Note that the aluminum beam conforms to the deposited BPSG, 

with equal thickness on the top and on the sidewalls of the BPSG. The BPSG is called a 

sacrifice layer because it is etched away when the MEMS process is complete. When the 

BPSG is removed, the fixed beam is held to the nitride by its conformal supports in the 

region where the BPSG holes were created. The section of the beam in the middle is now 

free to deflect when an external force, such as a pressure or electrostatic load, is applied. 



 

Fig. 3.17 Fabrication steps 

The Process Editor is accessed from an icon in the top half of the Function 

Manager. The initial process flow does not show the deposit and etch steps required to 

form the aluminum beam. In the steps below, the process file will be modified so an 

appropriate model can be built.  

In the Function Manager, click on the drop-down arrow to the right of Process filed. 

Select the beam_init.proc file located in the BeamDesign\Devices directory. Click on the 

Process Editor icon.  

 

Fig. 3.18 Process Editor for the beam_init.proc file 



The Process Description identifies all the steps used in creating the beam design. 

The Process Library provides the modeling step options. The Step Parameters pane 

allows the user to set parameters for a selected step in the Process Description. The 

Substrate in the Process Description pane corresponds to the ground plane, the next 

Stack Material corresponds to the Silicon Nitride layer, and the next Stack Material and 

Straight Cut steps correspond to the defined BPSG material on which the aluminum beam 

is placed. Finally, the BPSG delete step is shown at the end. 

In the Process Description pane, highlight Step 3 (Straight Cut) by clicking on the 

fourth row. On the right-hand side of the Process Editor, in the Process Library pane, 

double-click on Modeling Actions to expand the folder. Right-click on Conformal Shell and 

select Insert Below Current Step. Right-click on Straight Cut and insert it below the current 

step. Highlight Step 4 (Conformal Shell) in the Process Description pane, and enter the 

following attributes into the Step Parameter fields: 

• Layer Name: enter beam (or another descriptive name) 
• Material: select ALUMINUM(FILM) 
• Thickness Nominal Value: enter 0.5 
• Display Color: select red 

Select Step 5 (Straight Cut) and enter the following attributes: 

• Select Cut Last Layer Completely 
• Select Front Side 
• Mask: enter beam 
• Photoresist: select + 

The beam process is now complete. The finished Process Description pane of the 

Process Editor should look as shown below. 

 

Fig. 3.19 Process Editor for the beam_init.proc file after edits 

From the menu at the top of the Process Editor, select on File→Save As. Type the 

new file name beam.proc in the File name field. Click on Save. From the File menu, select 

Exit. 



LAYOUT EDITOR 
• Layout process 

o Multi-layer mask sets 
o Cell hierarchy 
o Boolean operations 
o Curved shapes 

• MEMS-specific features 
o Any-angle feature 

creation 
o Multi-copy by 

translation or rotation 
• Links directly to process 

simulation and mesh 
generation 

• Compatible with GDSII & 
DXF 

 

Fig. 3.20 2D layout of the beam 

After defining material properties and the deposit and etch sequence, the next step 

in creating a MEMS design is creating the 2-D layout. The 2-D Layout Editor is used to 

create, import, view, and edit 2-D mask information. The Layout functions are accessed by 

selecting the Designer tab from the Function Manager. From this window, the user selects 

a cat file. The cat file is the storage location for the 2-D layout created or edited in the 

Layout Editor. This cat file can include any number of individual cell layouts. The 2-D 

layout information can be used to create foundry masks for building the MEMS device and 

is used as the source for rendering a 3-D model for meshing and solving. In the next step, 

the 2-D mask layout will be viewed in the Layout Editor.  

From the Function Manager, click on the tab labeled Designer. Click on the Browse 

icon to the right of the Layout field. Select the beam.cat file in the BeamDesign\Devices 

directory. Click on Open. Click on the Layout Editor icon. 

BUILDING THE SOLID MODEL AND MESHING 

A 3-D model must be designed using the thickness and etch profile information from 

the process file and 2-D layout mask information. The Preprocessor tool can be used and 

the do necessary name settings and face selections. After that, a very important step is 

meshing the structure. Meshing is done to present the structure to the solver for finite 

element analysis. There are many types of meshing, and the user must select the one 

appropriate for his application. The most important areas must be meshed with a greater 

number of polygons to obtain accurate results, and the areas that do not present a very 



high interest can have a rougher mesh, for not loading the processor very much (thus 

obtaining a shorter simulation time). In our case, a Quadrilateral mesh type was selected 

for the ground and Manhattan Bricks was selected for the beam.  

Building the Solid Model 

To build the solid model of the beam, the first step is to click on the down arrow 

Model/Mesh field and select the option Create a new model. Then click on the Build a New 

3D Model icon and in the Input dialog that opens enter beam. After the build is finished the 

Preprocessor will automatically open. 

 

Fig. 3.21 Preprocessor Rendering of the Beam Model 

Meshing 

To assign the Manhattan bricks 

mesh type to the Substrate layer, from 

the Geometry Browser, click on the 

region containing the Substrate layer and 

then right click and select Mesher 

Settings. Select the Manhattan bricks 

mesh type. For setting the Element Size, 

enter the following: 

• For X direction: 2 
• For Y direction: 2 
• For Z direction: 10 

 
 

Fig. 3.22 Meshing in CoventorWare 



 

Fig. 3.23 Mesher Settings 

To assign the Manhattan bricks mesh type to the Beam layer, click on the region 

containing the beam layer. Then apply the same mesher settings. After all the settings 

were done create the mesh by clicking on the Generate Mesh icon. 

 

Fig. 3.24 Meshed Substrate and Beam 

MEMELECTRO SIMULATIONS 

First analysis is the uncoupled electrostatic simulation, MEMElectro. The 

MEMElectro solver produces an electrostatic solution by solving for the charge and 

capacitance interaction between the beam and the ground components. It uses the 

Boundary Element Method (BEM). MEM Electro computes the charge on each surface 



panel and presents a final solution with charge distribution calculated for all the panels in 

the model.   

From the Function Manager, click on the Analyzer tab to set up the Analyzer tab to 

point to the MemElectro solver for the beam model. After the window opened click on the 

arrow to the right of the Solver field, and from the dropdown menu, select MemElectro. 

Then click on the arrow beside the Model/Mesh field and select the beam model. In the 

Analysis field, verify that create a new analysis is displayed. Click on the Solver Setup 

icon. 

 

Fig. 3.25 MemElectro window 

Conductor beam is adjusted to have 1 V potential. The resulting ground and self-

capacitances of the structure can be seen below. Notice that beam-beam or ground-

ground capacitances are the self-capacitances of the structure. 

 

Fig. 3.26 ConductorBCs window 

In the MemElectro BCs window click on ConductorBCs and modify the fields so the 

conductor beam has a 1 V stimulus applied. After the settings was applied click on Run to 

start the simulation. After the Run Analysis window opens enter electro_run1 in the 

Analysis Label field and click OK. 



 
 

Fig. 3.27 Run Analysis window Fig. 3.28 Analysis electro_run1 window 

After the simulation is finished open the Analysis electro_run1 results by clicking on 

the View Results icon. To view the electrostatic results, click on the arrow beside the 

Tables field and select Capacitance Matrix (pF) from the drop-down menu and then click 

on the View Table icon. 

  

Fig. 3.29 Electrostatic results 

To view the 3-D charge results click on the View 3D Results icon and then select 

Coventor→Geometry Scaling. In the Scaling panel change the Z Scale field to 5. 

 

Fig. 3.30 The 3-D view shows the mapped charges 



MEMMECH SIMULATIONS 

Mechanical analysis can be performed using MemMECH which solves for the 

mechanical stress and displacement at each node. From the surface boundary conditions 

window, pressure load of 0.001 MegaPascals is applied onto the top surface of the beam 

in –z direction. The results of displacements in each direction and the applied reaction 

forces on the anchors are shown below: 

 
 

Fig. 3.31 The results of displacements in each direction and the applied reaction 
forces 

To set up the Analyzer tab to point to the MemMech solver for the beam model click 

on the arrow to the right of the Solver (effects) field, and from the drop-down menu, select 

MemMech and then select the beam model. After the selection was made click on the 

Solver Setup icon. After the verification of the default settings in the MemMech Settings 

dialog, click on the SurfaceBCs from the MemMech BCs window to open the SurfaceBCs 

dialog to fix the anchor faces. Modify Set 1 as described: for FixType select fixAll, for 

Patch1 select anchor1, for and1 select or, for Patch2 select anchor2 and for the rest of the 

Set1 line does not change.  

The next step is to apply a 0.001 MPa load to the top patch. To do this modify Set2 

as described: for FixType select LoadPatch, for Patch1 select top, for LoadValue type 

select Scalar and for LoadValue enter 0.001. Do not change any of the Boolean settings. 

After all the settings were done start the MemMech simulation by clicking Run in the 

MemMech BCs window and save the analysis results as mech_run1. When the simulation 

is finished click on the View Results icon and select mechDomain from the Tables drop-

down menu and then click on the View Table icon to review the mechanical results. Select 

rxnForces from the Tables drop-down menu and then click on the View Table icon to verify 

the rxnForces results. 



To view the 3-D mechanical results click on the View 3D Results icon and from the 

Visualizer menu bar select Plot→Contour/Multi-coloring. In the dialog that opens, select 

Mises Stress from the drop-down menu then click on Close. Select Coventor→Geometry 

Scaling and set Scale Z to 5. Select Deform Using Displacements, and set the 

Exaggeration to 15. 

 

Fig. 3.32 3-D display shows surface stress along the beam surface which shows 
that maximum deflection is at the beam center and maximum surface stress is at 

the fixed anchors 

COSOLVEEM SIMULATIONS 

 

Fig. 3.33 Coupling effects 

The CoSolveEM solver couples the electrostatic and mechanical solvers. The 

electrostatic results are input to the mechanical solver, and the results are used as 



feedbacks until convergence is achieved. Before starting with this analysis, the external 

pressure load is removed from the system. The voltage for the beam is set to 20 V. 

The first step is to remove the pressure load applied in the MemMech simulation by 

opening the MemMech SurfaceBCs and changing the Set2 LoadValue to 0.0. Then, from 

the Analyzer tab set the Solver field to CoSolveEM. From the Model/Mesh drop-down 

menu select the beam model and click on Solver Setup. In the CoSolveEM Settings dialog, 

set the Independent Variable to Voltage and then set the Analysis Option field to Single 

Step and the Iteration Method to Relaxation. 

 

Fig. 3.34 CoSolveEM Settings 

In the CoSolveEM BCs window click on the ConductorBCs and change the voltage 

for the beam to 20 V. Then click Run to start the simulation and save the analysis as 

cs_run1. 

 

Fig. 3.35 ConductorBCs window 

To view the numerical displacement results, click in the View Results icon and 

select Displacement from the Tables drop-down menu and click on the View Table icon. 

 



Fig. 3.36 Displacement results 

To view the Capacitance results, select Capacitance and to view the Voltage results 

on Conductors select Voltage. 

  

Fig. 3.37 Capacitance results Fig. 3.38 Voltage results 

TO view the Charge results on Conductors, select Charge and to view the Reaction 

Force results select Reaction Force. 

  

Fig. 3.39 Charge results Fig. 3.40 Reaction Force results 

To view the 3-D charge results start the Visualizer by clicking on the View 3D 

Results icon. In the MemElectro Results frame select Coventor→Geometry Scaling and 

set the Z Scale to 5. Then select Plot→Contour/Multi-coloring and display the Charge 

Density results. 

 

Fig. 3.41 CoSolve Surface Visualization of Results 



To view the 3-D mechanical results select Frame→Push Active Frame. Then select 

Plot→Contour/Multi-coloring and Mises Stress. Set the Geometry Scaling dialog as: Scale 

Z to 5, select Deform Using Displacements and Exaggeration to 50. 

 

Fig. 3.42 CoSolve Mechanical Results 

PARAMETRIC STUDY 

Parametric study is used to see the effects changing stress step by step with a 

constant pressure load. The initial stress is changed while applying a constant pressure 

load of 0.001 MegaPascals. The step size was set to 5 steps.  

From the Analyzer tab, select the beam model from the Model/Mesh field and click 

on the Start Preprocessor icon and the save the model as beam_stress. Then click on the 

Part Selection icon and then on the beam. Select Edit→Properties and click on the MPD 

Editor icon. After the MPD Editor window opens change the ALUMINIUM(FILM) Stress 

values to 10,10,0 for Sx,Sy and Sz. The next step is to select MemMech as the solver from 

the Analyzer tab and select beam_stress model. Select create a new analysis and click on 

the Solver Setup icon. In the Settings dialog set the Time Dependence back to Steady-

State and in the MemMech BCs window click on SurfaceBCs. Set the parameters as 

shown below. 



 

Fig. 3.43 SurfaceBCs window with the reapplied 0.001 pressure load to the top 
patch 

To access the MemMech Parametric Study Function click on the Parametric Study 

in the MemMech BCs window. 

 

Fig. 3.44 Parametric Study window 

Click on Trajectories and set the t1 TrajectoryType to Delta. Set the Delta trajectory 

of 5 steps by clicking on Edit. Set the values as shown below. 

 

Fig. 3.45 Set up of the Delta trajectory of 5 steps 



Click on MaterialProperties and set the MaterialProp1 Property to Stress. Set the 

Trajectory to t1, the Type to Factor, the ScaleFactor to 1.0 and the Material to 

ALUMINUM(FILM). Then start the simulation by clicking Run in the Parametric Study 

window. In the Run Analysis window enter mech_para. 

To view the numerical and graphical mechDomain results select mechDomain from 

the Tables drop-down menu for the numerical results (see figure 3.46) and for the 

graphical results (see figure 3.47) select mechDomain from the Graphs drop-down menu 

and then click on the View Graph icon. 

 

 

Fig. 3.46 Parametric Study mechDomain numerical results 



 

Fig. 3.47 Parametric Study mechDomain graphical results 

To view the displacement results in the Visualizer, click on the arrow beside the 

Load Results view and select All results and then click on the View 3D Results icon. Select 

Coventor→Part Visibility and move the ground part to the Visible column and then select 

Plot→Contour/Multi-coloring and then select Displacement Y from the drop-down menu. 

Select Coventor→Geometry Scaling and set the Z Scale to 5, check Deform Using 

Displacements and set Exaggeration to 10. To view the results for each trajectory step 

select Coventor→Result Selection. 



 

Fig. 3.48 Displacement in the y-direction 

3.4. MIRROR DESIGN 

3.4.1. SIMPLE MIRROR DESIGN 

Let’s see a more complex example: designing a mirror that rotates around an 

attached support. A thin multisided aluminum plate will rotate about an axis which is a 

support rod. The aluminum plate is rotated by applying voltages to the electrodes that are 

placed under the mirror ends. First the 3D structure is designed with the given deposition 

and etching steps. 

 

Fig. 3.49 Process Editor window 

 



  

Fig. 3.50 The created 3D structure and the meshed structure 

After that CoSolve single step simulations are done with voltages of 5 and 10V to 

electrode1 and 2 respectively. The results taken are shown below. 

  

Fig. 3.51 The Capacitance results Fig. 3.52 The electroBCs results 

 
 

Fig. 3.53 The mechDomain results Fig. 3.54 The rxnForces results 

The probes are connected to the electrodes are the voltage values are recorded. 

One example is shown: 



 

Fig. 3.55 Probe window 

After that 3D stress results are investigated. 

 

Fig. 3.56 The 3D stress results 

After the single step simulation, multiple CoSolve analyses is done. Displacement 

values are given below. 

 

Fig. 3.57 The displacements results 

 

 

 



3.4.2. FOUR-LAYER OPTICAL MIRROR 

 

Fig. 3.58 Four-layer optical mirror 

In the following part the software tool that will be used is CoventorWare. It will be 

designed a solution for four-layer optical mirror. 

After the CoventorView started select the Import Tutorial icon and then select 

Designer. Enter the designer.mps and click Open. After select the Start Layout Editor and 

from the Layout Editor menu bar select File→New→From Template….In the Template file 

name navigation window that opens select foundry.cat and then save the file as 

micromirror.cat. From the menu bar select Other→Grid and change the Working Grid to 

1.0.  

 



Fig. 3.59 Screen Illustrations 

The next step is to draw a four-layer mirror using the values from the table below. 

 

Fig. 3.60 Mirror Object values 

On the top of the window, on the lower row icons click on the arrow to the right of 

the Current layer name and select poly2. Along the vertical icon column, select the 

Rectangle icon. While viewing the coordinate reading in the lower left corner of the canvas 

window, move the mouse to the left in an attempt to reach coordinate -50, 0 and click. 

Move the mouse to coordinate 50, 100 and click. View your work by selecting the View All 

icon in the lower horizontal row.  

Then select from the Current layer list p12via. Along the lower horizontal icon row, 

click on Turn Repeat Mode On. From the vertical icon column, select the Circle icon. In 

response to the Enter center coordinate prompt, move the mouse to coordinate 0, 50 and 

click (to define the center). In response to the Enter point on radius prompt, move the 

mouse to coordinate 47, 50 and click (to define the radius). 

The next step is to select metal from the Current layer list. Place coordinate 0, 50. 

Place coordinate 46, 50. Right click to end the prompts for more circle coordinates. 

The final step is to select poly1 from the Current layer list. Select the Rectangle 

icon. Place coordinate -54, -4 (zoom as necessary). Place coordinate 54, 104. Right click 

to end the rectangle coordinate prompts. 

Select Save Cell As.. and in the window that opens enter mirror.  



 

Fig. 3.61 Four sequenced layers 

Along the top icon row, click on the arrow next to New File and select New Cell. 

From the vertical icon column, select the Reference icon. In the dialog window that opens, 

click on the Browse button next to Cell, and select mirror. In the Origin field, enter 0, 0. 

Click on Apply and Close. Click on the View All icon in the lower horizontal row. From the 

menu bar, select Cell→Copy .... In the dialog window that opens, next to the Source library 

field, click on Browse... and select the partial_cells.cat file. Next to the Source cell field, 

click on Browse... and select popupmech. In the Destination field, type popupmech. Click 

on Apply. Continue using the same copy procedure to copy the other four cells into your 

existing library. When finished, Close the dialog window. 

 

Fig. 3.62 Reference dialog window 



 

Fig. 3.63 Illustration of the concept of copied cells 

 

 

Fig. 3.64 Illustration of the concept of copied cells 

To create the popupmech cell reference, from the vertical icon column, select the 

Reference icon. In the dialog window that opens, click on the Browse button next to Cell, 



and select popupmech. In the Origin field, enter 0, 0. Click on Apply and Close. Click on 

View All.  

To create a new clip layer first click on the Layer browser icon, next to the Current 

layer list and then, in the window that opens, from the menu bar, select Layer→New… In 

the dialog window, enter the Layer name clip. Click on the Color name arrow and select 

the color red from the menu. Click on Apply and Close. 

To build a clip rectangle select the clip layer, the Rectangle icon and place 

coordinates -59, 50 and 59, 105. Right click to end the prompts for more rectangle 

coordinates.  

Save the cell by using the arrow next to the diskette icon and then select Save Cell 

As... In the window, enter popup; click on OK. Click on the diskette icon to save your 

micromirror.cat file. 

To check the hierarchy of the reference cells from the menu bar, select View→ 

Levels and uncheck Level 1. When finished, from the menu bar, select View→Levels→All. 

In the Layout Editor Cell Browser window, click on the + next to popup and observe the 

reference cells. 

 

Fig. 3.65 Creating the clip layer 

To set source catapult file and the Top Cell fields, on the Layout tab of the Function 

Manager, verify or set the Source Catapult File to Designer\Devices\micromirror.cat. Verify 

or set the Top Cell field to popup. To set the file path select the Foundry tab (see figure 

3.66). To set the Process file path, in the window of the Process field, set the path to the 



Designer\Devices directory and select the foundry.proc file. Navigate using the folder icon 

next to the field.  

To view the Process Editor file select the Foundry tab and then click on the icon to 

the right of the Process File field (see figure 3.67) to open the process Editor. Close when 

finished.  

To create the file name for the solid model, from the Function Manager, select the 

Solid Model tab. A default sat file will appear in the Solid Model field. Verify that the Solid 

Model File is named micromirror.sat. 

 

Fig. 3.66 Foundry tab  

 

 

Fig. 3.67 Process Editor window 

To build the 3-D model click on Build Model option. The Preprocessor opens 

automatically after a successful build. To view the 3-D click on the View Model option. At 



the top of the Preprocessor window, click on the Isometric View and Normalize icons to 

adjust the view.  

 

Fig. 3.68 Mirror Assembly 

To repeat build and view with Clip layer first in the Function Manager, Solid Model 

Tab, check the box next to Clip Device with Mask and verify that the layer name field is set 

to clip. Verify that the Top Cell is still popup. Click on Build Model. Click on Isometric View 

and Normalize. In the Designer Setup window, uncheck the box next to Clip layer. 

 

Fig. 3.69 Clip layer view 

 

 

 

 

 

 

 



 

3.4.3. THERMALLY-ACTUATED POP-UP MIRROR 

The thermally actuated mirror design has numerous applications, including optical 

switching and scanning. The mirror is controlled by an array of actuators connected to the 

mirror.  

 

Fig. 3.70 SEM image of Pop-up mirror 

 

Fig. 3.71 SEM image of complete scanning micromirror assembly 

 

Fig. 3.72 Designer 3D model of micromirror assembly 



The mirror that makes up part of the device is known as a pop-up mirror because it 

is flat when fabricated, but extends out from the wafer plane when in use. It uses a layer of 

gold as its optical reflector. In this design, the mirror is manually assembled to a nearly 

vertical position and locked in place by a rod connected to the actuator. The mirror rotates 

around pins that are held to the substrate by staple-like structures that function as hinges.  

The thermal actuator, or heatuator, uses differential thermal expansion to provide 

high forces and substantial linear motion. To increase the available force, this design uses 

a parallel combination of ten thermal actuators. The heat is generated by passing current 

through the device. This actuator is designed to pull the mirror to avoid flexing the 

connecting rod. Each actuator is capable of over 20 µN of force and over 10 µm of 

deflection at an input electrical power of 25 mW (at 5 V and 5 mA). A 5 x 2 array used here 

can provide 200 µN of force while consuming 250 mW. 

The conductors used to feed this device are thick enough to prevent significant 

parasitic voltage drops for 50 mA of current and to reduce the associated power loss. 

Because this is a significant amount of power, the fabricated chip must be bonded to a 

thermally efficient heat sink. 

In the following part the software tool that will be used is CoventorWare. It will be 

designed a solution for thermally-actuated pop-up mirror. 

After the CoventorView started select the Import Tutorial icon and then select 

Designer. Enter the designer.mps and click Open. After select the Start Layout Editor and 

from the Layout Editor menu bar select File→New→From Template….In the Template file 

name navigation window that opens select foundry.cat and then save the file as 

micromirror.cat. From the menu bar select Other→Grid and change the Working Grid to 

1.0.  



 

Fig. 3.73 Screen Illustrations 

The next step is to draw a four-layer mirror using the values from the table below. 

 

Fig. 3.74 Mirror Object values 



On the top of the window, on the lower row icons click on the arrow to the right of 

the Current layer name and select poly2. Along the vertical icon column, select the 

Rectangle icon. While viewing the coordinate reading in the lower left corner of the canvas 

window, move the mouse to the left in an attempt to reach coordinate -50, 0 and click. 

Move the mouse to coordinate 50, 100 and click. View your work by selecting the View All 

icon in the lower horizontal row.  

Then select from the Current layer list p12via. Along the lower horizontal icon row, 

click on Turn Repeat Mode On. From the vertical icon column, select the Circle icon. In 

response to the Enter center coordinate prompt, move the mouse to coordinate 0, 50 and 

click (to define the center). In response to the Enter point on radius prompt, move the 

mouse to coordinate 47, 50 and click (to define the radius). 

The next step is to select metal from the Current layer list. Place coordinate 0, 50. 

Place coordinate 46, 50. Right click to end the prompts for more circle coordinates. 

The final step is to select poly1 from the Current layer list. Select the Rectangle 

icon. Place coordinate -54, -4 (zoom as necessary). Place coordinate 54, 104. Right click 

to end the rectangle coordinate prompts. 

Select Save Cell As.. and in the window that opens enter mirror.  

 

Fig. 3.75 Four sequenced layers 



Along the top icon row, click on the arrow next to New File and select New Cell. 

From the vertical icon column, select the Reference icon. In the dialog window that opens, 

click on the Browse button next to Cell, and select mirror. In the Origin field, enter 0, 0. 

Click on Apply and Close. Click on the View All icon in the lower horizontal row. From the 

menu bar, select Cell→Copy .... In the dialog window that opens, next to the Source library 

field, click on Browse... and select the partial_cells.cat file. Next to the Source cell field, 

click on Browse... and select popupmech. In the Destination field, type popupmech. Click 

on Apply. Continue using the same copy procedure to copy the other four cells into your 

existing library. When finished, Close the dialog window. 

 

Fig. 3.76 Reference dialog window 

 

Fig. 3.77 Illustration of the concept of copied cells 

 



 

Fig. 3.78 Illustration of the concept of copied cells 

To create the popupmech cell reference, from the vertical icon column, select the 

Reference icon. In the dialog window that opens, click on the Browse button next to Cell, 

and select popupmech. In the Origin field, enter 0, 0. Click on Apply and Close. Click on 

View All.  

To create a new clip layer first click on the Layer browser icon, next to the Current 

layer list and then, in the window that opens, from the menu bar, select Layer→New… In 

the dialog window, enter the Layer name clip. Click on the Color name arrow and select 

the color red from the menu. Click on Apply and Close. 

To build a clip rectangle select the clip layer, the Rectangle icon and place 

coordinates -59, 50 and 59, 105. Right click to end the prompts for more rectangle 

coordinates.  

Save the cell by using the arrow next to the diskette icon and then select Save Cell 

As... In the window, enter popup; click on OK. Click on the diskette icon to save your 

micromirror.cat file. 



To check the hierarchy of the reference cells from the menu bar, select View→ 

Levels and uncheck Level 1. When finished, from the menu bar, select View→Levels→All. 

In the Layout Editor Cell Browser window, click on the + next to popup and observe the 

reference cells. 

 

Fig. 3.79 Creating the clip layer 

To set source catapult file and the Top Cell fields, on the Layout tab of the Function 

Manager, verify or set the Source Catapult File to Designer\Devices\micromirror.cat. Verify 

or set the Top Cell field to popup. To set the file path select the Foundry tab (see figure 

3.80). To set the Process file path, in the window of the Process field, set the path to the 

Designer\Devices directory and select the foundry.proc file. Navigate using the folder icon 

next to the field.  

To view the Process Editor file select the Foundry tab and then click on the icon to 

the right of the Process File field (see figure 3.81) to open the process Editor. Close when 

finished.  

To create the file name for the solid model, from the Function Manager, select the 

Solid Model tab. A default sat file will appear in the Solid Model field. Verify that the Solid 

Model File is named micromirror.sat. 



 

Fig. 3.80 Foundry tab  

 

 

Fig. 3.81 Process Editor window 

To build the 3-D model click on Build Model option. The Preprocessor opens 

automatically after a successful build. To view the 3-D click on the View Model option. At 

the top of the Preprocessor window, click on the Isometric View and Normalize icons to 

adjust the view.  



 

Fig. 3.82 Mirror Assembly 

To repeat build and view with Clip layer first in the Function Manager, Solid Model 

Tab, check the box next to Clip Device with Mask and verify that the layer name field is set 

to clip. Verify that the Top Cell is still popup. Click on Build Model. Click on Isometric View 

and Normalize. In the Designer Setup window, uncheck the box next to Clip layer. 

 

Fig. 3.83 Clip layer view 

 

 

 

 

 

 



The next step is to draw a heatuator using the values from the table below. 

 

Fig. 3.84 Heatuator object summary 

Along the top icon row, click on the arrow next to New File and select New Cell. To 

build the lower anchor pad in poly1 select poly1 and then select the Rectangle icon. Place 

coordinates 0, 0 and 11, 11. To build in poly1 the lower long arm place coordinates 11, 9 

and 219, 11. To build the lower anchor select anchor1 and then place the coordinates 4, 4 

and 7, 7. Right click to end the Rectangle command. To create a mirrored copy of the 

three objects, click on one of the three components and then press and hold Shift while 

you select the other two objects. From the lower icon row, next to the Mirror icon, click on 

the arrow. Select Mirror Up. From the lower icon row, to the far right, select the Nudge 

icon. Click twice in the top middle section of the canvas. 

 

Fig. 3.85 Screen Illustrations 



To build the long thick arm on the poly1 layer select poly1 and then select the 

Rectangle icon. Place coordinates 51, 13 and 219, 17. To build the vertical connect place 

the coordinates 214, 9 and 219, 27. To build the dimple, who acts as a standoff for the 

sliding actuator arm, select the dimple layer and then place the coordinates 74, 19 and 77, 

22. Right click to end the Rectangle command. To copy and paste the remaining dimples 

click on the dimple to select it and then from the upper horizontal icon row select Copy. 

Click on the lower left corner of the dimple as the FROM point. If this is difficult, click when 

the coordinate readout is at 74, 19. From the upper horizontal icon row, select Paste. 

Place two copies of the dimple at coordinates 127, 19 and at 180, 19. Right click to end 

the Paste mode.  

Save the cell as heatuator. 

 

Fig. 3.86 The heatuator 

The next step is to complete the heatuator assembly by adding power connections 

to the anchor pads and a linkage arm to the assembly. 

Start a new cell by selecting New Cell from the upper icon row. Add heatuator as a 

cell reference at origin 0, 0 by selecting the Reference icon and then in the dialog window 

that opens, in the Cell field, select heatuator and in the origin field enter 0, 0. Add 

connector as a cell reference at origin -39, 0, by creating another cell reference 

(connector) and placing it as a cell reference at origin -39, 0. Add contact_pad as a cell 

reference at origin -9, 22, by creating another cell reference (contact_pad) and placing it 

as a cell reference at the origin -9, 22. Draw the linkage mechanism in poly1 as a path of 

width 2 by selecting first poly1 and from the menu bar Object→Path and the dialog window 

that opens set a width of 2. From the vertical icon column select Path and start it at 

coordinate 217, 26 and move right, then click at coordinate 224, 26 and move down, then 

click at coordinate 224, -8 and move right, then click at coordinate 230, -8 and move down 

and then click at coordinate 230, -55. Right click to end. Save the cell as heatuator_assy. 



 

Fig. 3.87 The heatuator assembly 

The next step is to create an array of ten heatuator assemblies and connect the 

array to a set of power rails. 

Create a new cell by selecting New Cell from the top icon row. From the vertical 

icon column click on the Reference icon and in the Cell field enter heatuator_assy. Set the 

Origin to 0, 0. Place an Array Reference of heatuator_assy cells (see figure 3.88) by 

selecting Array Reference and then in the Cell field click on Browse… button and select 

heatuator_assy.  Set the Array for a 40 unit Row distance (-46 unit Row spacing) by 

setting the Row distance field to 40. Set the Columns to 1 and Rows to 5. Set Origin to -1, 

0. Create a cell reference using the rails cell. Align anchor2 polygons with an origin of -39, 

-10 (see figure 3.88). Mirror Right to create a ten-cell array with full rail connections by 

clicking on the arrow next to the Select objects icon and then choosing Select rectangular 

area and then draw a box around the entire assembly to select it and from the horizontal 

icon menu select Mirror Right. Shift the mirrored portion two units to the left so the 

common poly is lined up. Save the cell as heatuator_array. 

 

Fig. 3.88 Array Reference dialog window 



 

Fig. 3.89 Heatuator_array cell 

The next step is to place the completed heatuator_array and popup cells and 

connect them with poly2.  

Create a new cell by selecting New Cell from the top icon row. Create a cell 

reference using the heatuator_array cell by selecting the heatuator_array cell in the 

Reference window and setting the Angle at 180 degrees and the Origin to 229, -30. Create 

a cell reference using the popup cell by selecting the popup cell in the Reference window 

and setting the Origin to 0, 120. Connect the poly1 linkage arms of the heatuator array and 

the long center connector of the popup mirror hinge assembly with a new poly1 rectangle. 

For exact placement, the coordinates are -7, 0 and 7, 48. Save the cell as mirror_array. 

Also save micromirror.cat. 



 

Fig. 3.90 Mirror Array 

For finalizing the project place the completed mirror_array cell, create a pad frame 

of bonding pads around the periphery of the layout and connect the bond pads to the 

power rails of the heatuator assembly.  

 

Fig. 3.91 Mirror Array with Padframe 

Create a new cell by selecting New Cell from the top icon row. Create a cell 

reference using the padframe cell by selecting padframe in the Reference window and 



setting the Origin to 0, 0. Create a cell reference using the mirror_array cell by selecting 

mirror_array in the Reference window and setting the Origin to 0, -50. Draw connector 

wires 14 units thick in poly2 from the power rails to 8 of the pad cells by connecting the 

poly2, after selecting it, of the two right side rails to the poly2 of the pads and using a path 

object of width 14. Connect rail tops and bottoms to different pads for optimal power 

distribution. Save the cell as scan_assy. 

To build the 3-D Model on the Layout tab of the Function Manager select scan_assy 

as the Top Cell and then click on the Solid Model tab of the Function Manager. Click then 

on the Build Model button. 

To view the 3-D Model select Edit→Edit Model from the Preprocessor menu bar. 

Then increase the Z Scale field value to see the layer depth in more detail. Select Part 

Display in the Edit Model window and remove some layers by highlighting layers in the left 

column and clicking on the Remove arrow icon to see only the active layers. When 

finished, from the Preprocessor menu bar, select File→Quit. 

 

Fig. 3.92 Thermally-actuated pop-up mirror views 
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